<!DOCTYPE html>
<html lang="en" prefix="og: http://ogp.me/ns#">
<head>
  <meta charset="UTF-8">
  
<link rel="icon"
      type="image/x-icon"
      href="/theme/images/favicon/rivertowns.ico" />

  <meta name="viewport" content="width=device-width, initial-scale=1">
  
  
                                                                                          
  <meta name="robots" content="index, follow" />

  


  <script>
    // global_data_tags is a global variable of article tags used in googletag.js
    // and global_domain is the domain for the page
    var global_data_tags = [{"name":"REPUBLICAN EAGLE","uri":"tags\/REPUBLICAN_EAGLE"},{"name":"Red Wing Wingers","uri":"tags\/red_wing_wingers"},{"name":"cannon falls bombers","uri":"tags\/cannon_falls_bombers"},{"name":"Lake City Tigers","uri":"tags\/lake_city_tigers"},{"name":"Randolph Rockets","uri":"tags\/randolph_rockets"},{"name":"Ellsworth Panthers","uri":"tags\/ellsworth_panthers"},{"name":"prescott cardinals","uri":"tags\/prescott_cardinals"},{"name":"Spring Valley Cardinals","uri":"tags\/spring_valley_cardinals"}];
    var global_domain = "rivertowns";
  </script>
        
                  
        
  
  
      
            
                      
                                                                  
        
        
        
            
                                              
                
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    <meta property="description" content="The Pierce and Goodhue County area sports teams collectively had another successful year in 2019. These are some of the top moments of the year." />
    <meta property="fb:app_id" content="183850698474489" />
    <meta property="og:title" content="Top-10 Republican Eagle Sports Stories: Plenty of success at state | RiverTowns" />
    <meta property="og:url" content="/sports/4847241-Top-10-Republican-Eagle-Sports-Stories-Plenty-of-success-at-state" />
    <meta property="og:type" content="website" />
    <meta property="og:site_name" content="RiverTowns" />
    <meta property="og:description" content="The Pierce and Goodhue County area sports teams collectively had another successful year in 2019. These are some of the top moments of the year." />
    <meta property="og:image" content="https://www.rivertowns.net/incoming/4847313-oqzy3x-Top-10-Randolph-Section-Baseball.jpg/alternates/BASE_LANDSCAPE/Top-10%20Randolph%20Section%20Baseball.jpg" />
    <meta property="og:image:height" content="1140" />
    <meta property="og:image:width" content="712" />
    <meta property="og:video" content="" />
    <meta property="og:video:width" content="" />
    <meta property="og:video:height" content="" />
    <meta property="twitter:image" content="https://www.rivertowns.net/incoming/4847313-oqzy3x-Top-10-Randolph-Section-Baseball.jpg/alternates/BASE_LANDSCAPE/Top-10%20Randolph%20Section%20Baseball.jpg" />
    <meta property="twitter:url" content="/sports/4847241-Top-10-Republican-Eagle-Sports-Stories-Plenty-of-success-at-state" />
    <meta property="twitter:title" content="Top-10 Republican Eagle Sports Stories: Plenty of success at state | RiverTowns" />
    <meta property="twitter:site" content="RiverTowns" />
    <meta property="twitter:card" content="summary_large_image" />
  
    <title>Top-10 Republican Eagle Sports Stories: Plenty of success at state | RiverTowns</title>

    <link rel='canonical' href="/sports/4847241-Top-10-Republican-Eagle-Sports-Stories-Plenty-of-success-at-state" />

    <!-- Piano -->
<script>
    var pianoInitData = new Object();
  var pianoInitRunStack = new Array();

  document.cookie = "__adblocker=; expires=Thu, 01 Jan 1970 00:00:00 GMT; path=/";
  var setNptTechAdblockerCookie = function(adblocker) {
      var d = new Date();
      d.setTime(d.getTime() + 60 * 60 * 24 * 2 * 1000);
      document.cookie = "__adblocker=" + (adblocker ? "true" : "false") + "; expires=" + d.toUTCString() + "; path=/";
  };
  var script = document.createElement("script");
  script.setAttribute("async", true);
  script.setAttribute("src", "//www.npttech.com/advertising.js");
  script.setAttribute("onerror", "setNptTechAdblockerCookie(true);");
  document.getElementsByTagName("head")[0].appendChild(script);
</script>
<script src="https://code.jquery.com/jquery-3.3.1.min.js" integrity="sha256-FgpCb/KJQlLNfOu91ta32o/NMZxltwRo8QtmkMRdAu8=" crossorigin="anonymous"></script>
<!-- Load Custom Modernizr to detect CSS Grid feature -->
<script type="text/javascript" src="/theme/js/modernizr.grid.min.js"></script>
<!-- Load Custom lazyload plugin -->
<script type="text/javascript" src="/theme/js/jquery.lazyload.js"></script>
<!-- Load Custom slider plugin -->
<script type="text/javascript" src="/theme/js/jquery.fcc_slider.js"></script>
<!-- Load JW Player -->
<script type="text/javascript" src="/theme/js/jwplayer/jwplayer.js"></script>
<script type="text/javascript">jwplayer.key="DVZLaA/7aF2XVZKVNeDg9YvndeF1lTr2lO51IYwmkiYRLuEg";</script>
<!-- WSI Weather -->
<script type="text/javascript" src="https://widgets-lts.media.weather.com/wxwidget.loader.js?cid=315354512"></script>
<!-- Load sha1 encoder -->
<script type="text/javascript" src="/theme/js/sha1.js"></script>


<!-- Google Tag Manager -->
<script>
      dataLayer = [{
    'page_category': ''
  }];
</script>
<script type="text/javascript" src="/theme/js/fccgtminit.js"></script>
<!-- End Google Tag Manager -->

    <!-- Load GPT code -->
  <script src="//www.googletagservices.com/tag/js/gpt.js"></script>
  <!-- Load Prebid -->
  <script src="/theme/js/prebid.min.js"></script>
  <!-- DFP tags -->
  <script type="text/javascript" src="/theme/js/googletag-prebid.js"></script>

  <!-- ChartBeat -->
              
           
  <script type='text/javascript'>
    (function() {
      /** CONFIGURATION START **/
      var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
      let domain = window.location.hostname;
      _sf_async_config.uid = 63431;
      _sf_async_config.domain = domain;
      _sf_async_config.flickerControl = false;
      _sf_async_config.useCanonical = true;
      _sf_async_config.useCanonicalDomain = true;
      _sf_async_config.sections = 'Sports';
      _sf_async_config.authors = 'RE Sports';
      _sf_async_config.type = 'article';
      var _cbq = window._cbq = (window._cbq || []);
      /** CONFIGURATION END **/
      function loadChartbeat() {
        var e = document.createElement('script');
        var n = document.getElementsByTagName('script')[0];
        e.type = 'text/javascript';
        e.async = true;
        e.src = '//static.chartbeat.com/js/chartbeat_video.js';
        n.parentNode.insertBefore(e, n);
      }
      loadChartbeat();
    })();
  </script>
  <script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
  <!-- End ChartBeat -->

  <!-- Nativo -->
  <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
  <!-- End Nativo -->

  <!-- DFP Pixels -->
  

      
<script type='text/javascript'>
    var axel = Math.random() + '';
    var a = axel * 10000000000000;
    document.write('<img src="https://pubads.g.doubleclick.net/activity;dc_iu=/7021/DFPAudiencePixel;ord=' + a + ';dc_seg=757967826?" style="float:left;" width=1 height=1 border=0/>');
</script>

<noscript>
  <img src="https://pubads.g.doubleclick.net/activity;dc_iu=/7021/DFPAudiencePixel;ord=1;dc_seg=757967826?" style="float:left;" width=1 height=1 border=0/>
</noscript>
  <!-- End of DFP Pixels -->

<!-- Sailthru Personalization Engine -->
  <script src="https://ak.sail-horizon.com/spm/spm.v1.min.js"></script>
  <script>Sailthru.init({ customerId: '606bb09ea3b77f2d603ee5d5e588ed64' });</script>
<!-- End Sailthru Personalization Engine -->

<!-- Sublink iframe scrolling -->
<script type="text/javascript">

    window.addEventListener('message', function(event) {
        if (!event.origin.includes('newscyclecloud.com')) return;
        window.scrollTo(0, 0);
    }, false);

</script>
<!-- End Sublink iframe scrolling -->
    <link rel="stylesheet" type="text/css" href="/theme/css/weekly.css">
<link rel="stylesheet" type="text/css" href="/theme/css/owl.carousel.min.css">
    
   </head>
   <body>
           <!-- Google Tag Manager (noscript) -->
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-5GVGN9S" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager (noscript) -->
     
           <!-- Google Consumer Survey -->
            <script type="text/javascript">
          // Google Consumer Survey
          (function () {
              var ARTICLE_URL = window.location.href;
              var CONTENT_ID = 'everything';
              document.write(
                      '<scr' + 'ipt ' +
                      'src="//survey.g.doubleclick.net/survey?site=_gcnfumnktkq2nskptuv73ljuba' +
                      '&url=' + encodeURIComponent(ARTICLE_URL) +
                      (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                      '&random=' + (new Date).getTime() +
                      '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
          })();
      </script>
      <!-- Google Consumer Survey -->
    
    
          <header class="main-header" role="banner">
  <div id="bigLogo" class="site-masthead-container">
    <div class="site-masthead">
      <a href="/" class="logo-link" tabindex="1">
    <img id="bigLogoImage" src="https://static.forumcomm.com/images/620x220/rivertowns.png" onError="this.onerror=null;this.src='/theme/images/logos/logo_pngs/rivertowns.png';" alt="rivertowns logo">
  </a>
</div>
  </div>
  <div id="sticky-header" class="sticky-mobile">
    

<div id="topNav" class="top-nav">
  <div class="top-wrapper">

    <div class="current-weather">
      <a href="/news/weather/" tabindex="3">
        
<div class="header-weather-widget">
  <wx-config language="en" latitude="44.567610" longitude="-92.574351" header="false" group="true" icast="true"></wx-config>
  <wx-widget type="current-conditions" icast="true"></wx-widget>
</div>
      </a>
    </div>

    <div class="weather">
  <div class="header-weather">
    <!-- The "Weather Notifications" label is "display: none" by default and will only be shown if:
         1. There is a weatherAlertCount OR
         2. there is a weather announcement count greater than zero AND
         3. it is not already being shown in the weatherAlertCount block -->
    <a href="/news/weather/" class="weather-notifications-text" style="display: none;"></a>

        
      <!-- If there are weather announcements show this block in the nav -->
      <div class="weather-announcements" style="display: none;">
        <a href="/severe-weather">
          <div class="blue-circle announcements-count">0</div>
          <h5>Announcements</h5>
        </a>
      </div>

  </div>

  <script>

    $(document).ready(function(){

      getCountAJAX();

      function displayAnnouncementCount(announcementCount){
        // if announcement count greater than zero, display it on pages
        if(announcementCount > 0){
          $('.weather-announcements').show();
          $('.announcements-count').text(announcementCount);
          // Make sure we are showing the "Weather Notifications" label
          let weatherNotificationsText = $('.weather-notifications-text').text();
          if(weatherNotificationsText != "Weather Notifications"){
            // If "Weather Notifications" is not already showing from the weatherAlertCount block
            $('.weather-notifications-text').show();
            $('.weather-notifications-text').text("Weather Notifications");
          }
        }
        else{
          $('.current-weather').css('display','block');
        }
      }

      function getCountAJAX(){
        // Use ajax to get the number of weather announcements
        // For testing of getting all results in one request, use this URL:
        // 'https://enrichmentservices.fccinteractive.com/weather-announcements-all.php?publication=inforum&format=json&test_all=true',
        let feedCount = 0;
        $.ajax({
          type: "GET",
          url: 'https://enrichmentservices.fccinteractive.com/weather-announcements-all.php?publication=rivertowns&format=json&group=all',
          dataType: "json",
          success: (result) => {
            // console.log("weather ajax SUCCESS!:", result);
            for(i = 0; i < result.length; i++){
              closingList = result[i].closingGroup.closingList;
              feedCount += closingList.length;
            }
            displayAnnouncementCount(feedCount);
          },
          error: (error) => {
            console.log("weather announcements ajax FAILED", error);
          }
        });
      }
    });

  </script>

</div>

          <div class="e-paper-link">
        <a href="/account/e-paper"  title="E-Paper" target="_self" tabindex=>E-Paper</a>      </div>
    
    <div class="search-menu" tabindex="3">
      <a class="link search-icon" title="search" target="_self">
  <span class="search-label">Search</span> <svg class="icon-search" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32">
    <path d="M31.008 27.231l-7.58-6.447c-.784-.705-1.622-1.029-2.299-.998a11.954 11.954 0 0 0 2.87-7.787c0-6.627-5.373-12-12-12s-12 5.373-12 12 5.373 12 12 12c2.972 0 5.691-1.081 7.787-2.87-.031.677.293 1.515.998 2.299l6.447 7.58c1.104 1.226 2.907 1.33 4.007.23s.997-2.903-.23-4.007zM12 20a8 8 0 1 1 0-16 8 8 0 0 1 0 16z"></path>
</svg> 
</a>
    </div>

    <div id="search-popup">
  <div class="arrow-up-background"></div>
  <div class="arrow-up"></div>
  <div class="search-body">
    <form action="">
      <input type="text" placeholder="Search rivertowns" />
      <span class="input-search-icon"><svg class="icon-search" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32">
    <path d="M31.008 27.231l-7.58-6.447c-.784-.705-1.622-1.029-2.299-.998a11.954 11.954 0 0 0 2.87-7.787c0-6.627-5.373-12-12-12s-12 5.373-12 12 5.373 12 12 12c2.972 0 5.691-1.081 7.787-2.87-.031.677.293 1.515.998 2.299l6.447 7.58c1.104 1.226 2.907 1.33 4.007.23s.997-2.903-.23-4.007zM12 20a8 8 0 1 1 0-16 8 8 0 0 1 0 16z"></path>
</svg></span>
    </form>
  </div>
</div>

<script>
  $('html').click(function(event) {
    if($('#search-popup').is(":visible") && $(event.target).closest('#search-popup').length === 0){
      $('#search-popup').toggle("fast");
    }
  });

  $('.search-menu').click(function(event) {
    event.stopPropagation();
    $('#search-popup').toggle("fast");
    $('.search-body input').focus();
  });

  // Sanitizes the search input
  function searchFormSubmit(search_input) {
    if (search_input.val().length > 1) {
      let sanitizedSearchTerm = search_input.val().replace(/[^a-zA-Z0-9 ]/g, "")
      window.location.href = "/search/?q=" + encodeURIComponent(sanitizedSearchTerm);
    } else {
      alert("Please type in something to search");
      search_input.focus();
    }
  }

  // Desktop form
  $( "#search-popup form" ).submit(function( event ) {
    var search_input = $('#search-popup input');
    searchFormSubmit(search_input);
    event.preventDefault();
  });

  // Desktop/mobile form submit when clicking icon
  $( "form > .input-search-icon" ).on("click", function(event) {
    var search_input = $('#search-popup input');
    if (search_input.val().length < 1) { search_input = $('#search-popup-mobile input'); }
    searchFormSubmit(search_input);
    event.preventDefault();
  });
  </script>

  </div>
</div>

    <nav class="header">
  <div class="main-wrapper">

    <input class="menu-btn" type="checkbox" id="menu-btn" />
    <label class="menu-icon" for="menu-btn" tabindex="0"><span class="navicon"></span><span class="menu-label">Menu</span></label>

    <div class="home-logo">
      
<a href="/" class="logo-link" tabindex="1">

  <img src="https://static.forumcomm.com/images/300x86/rivertowns.png" onError="this.onerror=null;this.src='/theme/images/logos/logo_pngs/logo-small/rivertowns.png';" alt="rivertowns logo">

</a>
    </div>

    <div class="menu-outer">
      <ul class="menu">
                <div id="search-popup-mobile">
          <div class="search-body search-body-mobile">
            <form action="">
              <input type="text" placeholder="Search rivertowns" />
              <span class="input-search-icon"><svg class="icon-search" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32">
    <path d="M31.008 27.231l-7.58-6.447c-.784-.705-1.622-1.029-2.299-.998a11.954 11.954 0 0 0 2.87-7.787c0-6.627-5.373-12-12-12s-12 5.373-12 12 5.373 12 12 12c2.972 0 5.691-1.081 7.787-2.87-.031.677.293 1.515.998 2.299l6.447 7.58c1.104 1.226 2.907 1.33 4.007.23s.997-2.903-.23-4.007zM12 20a8 8 0 1 1 0-16 8 8 0 0 1 0 16z"></path>
</svg></span>
            </form>
          </div>
        </div>
                  <div>
            <li class="e-paper-link-mobile main-nav-item">
              <a href="/account/e-paper"  title="E-Paper" target="_self" tabindex=>E-Paper</a>            </li>
          </div>
          <div>
            <li id="myAccountButtonMobile" class="my-account-link-mobile main-nav-item">
              <a href="/account"  title="My Account" target="_self" tabindex=>My Account</a>            </li>
            <li id="loginButtonMobile" class="my-account-link-mobile main-nav-item">
              <a href="javascript:login();"  title="Log in" target="_self" tabindex=>Log in</a>            </li>
          </div>
                          <li class="main-nav-item">
            <a href="https://www.rivertowns.net/news/"  title="News" target="_self" tabindex=1>News</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/sports/"  title="Sports" target="_self" tabindex=1>Sports</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/opinion/"  title="Opinion" target="_self" tabindex=1>Opinion</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/videos/"  title="Videos" target="_self" tabindex=1>Videos</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/news/weather/"  title="Weather" target="_self" tabindex=1>Weather</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/business/"  title="Business" target="_self" tabindex=1>Business</a>          </li>
                  <li class="main-nav-item">
            <a href="https://www.rivertowns.net/obituaries/"  title="Obituaries" target="_self" tabindex=1>Obituaries</a>          </li>
        
        <li class="dropdown-list-item">
          <button class="header-more" tabindex="2">
            <div class="more-sections-button">
              Sections<span class="navicon top-navicon"> &#9660;</span>
            </div>
          </button>
          <ul class="dropdown-nav">
                          <li class="main-nav-item">
                <a href="https://www.rivertowns.net/entertainment/"  title="Entertainment" target="_self" tabindex=1>Entertainment</a>              </li>
                          <li class="main-nav-item">
                <a href="https://www.rivertowns.net/lifestyle/"  title="Lifestyle" target="_self" tabindex=1>Lifestyle</a>              </li>
                          <li class="main-nav-item">
                <a href="https://www.rivertowns.net/milestones/"  title="Milestones" target="_self" tabindex=1>Milestones</a>              </li>
                          <li class="main-nav-item">
                <a href="https://www.rivertowns.net/community/"  title="Community" target="_self" tabindex=1>Community</a>              </li>
                        <li>


<ul class="hq-nav main-nav-item">
      <li class="main-nav-item" ><a class="white-link" href="http://www.carshq.com" title="Motors" target="_blank" tabindex="1">Motors</a></li>
      <li class="main-nav-item" ><a class="white-link" href="https://www.jobshq.com" title="JobsHQ" target="_blank" tabindex="1">JobsHQ</a></li>
      <li class="main-nav-item" ><a class="white-link" href="https://www.homeshq.com" title="HomesHQ" target="_blank" tabindex="1">HomesHQ</a></li>
      <li class="main-nav-item" ><a class="white-link" href="http://www.apartmentshq.com" title="ApartmentsHQ" target="_blank" tabindex="1">ApartmentsHQ</a></li>
      <li class="main-nav-item" ><a class="white-link" href="/classifieds" title="Classifieds" target="_self" tabindex="1">Classifieds</a></li>
      <li class="main-nav-item" ><a class="white-link" href="https://searchmarketplaces.com/marketplace/rivertowns" title="Marketplace" target="_blank" tabindex="1">Marketplace</a></li>
  </ul>
</li>
          </ul>
        </li>
      </ul>
    </div>

    <div class="header-buttons">
      <div class="login">
          <a id="epaperLink" class="epaper-link" href="/account/benefits" target="_self" >
    <span class="epaper">benefits</span>
  </a>
  <a id="logInLink" class="log-in-link" href="javascript:login();" target="_self">
    <span class="my-account">log in</span>
  </a>
  <a id="myAccountLinkLeft" class="subscribe-btn" href="/account" target="_self">
    <span class="my-account">my account</span>
  </a>

<script>

  
        document.getElementById('logInLink').style.display = "none";
    document.getElementById('epaperLink').style.display = "none";

        pianoInitRunStack.push(waitForPianoInitLoginButton);

    function waitForPianoInitLoginButton() {
            var arrayLength = pianoInitData.data.length;
      if(arrayLength == 0) {
                document.getElementById('logInLink').style.display = "none";
        document.getElementById('myAccountLinkLeft').style.display = "table-cell";
      }
      else {
                for (var i=0; i < arrayLength; i++) {
          if(pianoInitData.data[i].granted == true) {
            document.getElementById('epaperLink').style.display = "table-cell";
            document.getElementById('logInLink').style.display = "none";
            break;
          }
          else {
            document.getElementById('myAccountLinkLeft').style.display = "table-cell";
          }
        }
      }
    }

        tp = window["tp"] || [];
    tp.push(['init', function() {
      if (!tp.user.isUserValid()) {
        document.getElementById('logInLink').style.display = "table-cell";
      }
    }]);

  </script>
      </div>

      <div class="subscribe">
            <a id="myAccountLink" class="subscribe-btn" href="/account" target="_self">
    <span class="my-account">my account</span>
  </a>
  <a id="subscribeLink" class="subscribe-btn" href="/subscribe">
    <span class="my-account">Subscribe</span>
  </a>


  <script>
    
        document.getElementById('subscribeLink').style.display = "none";
    document.getElementById('myAccountLink').style.display = "none";

        pianoInitRunStack.push(waitForPianoInitSubscribeButton);

    function waitForPianoInitSubscribeButton() {
            var arrayLength = pianoInitData.data.length;
      if(arrayLength == 0) {
                document.getElementById('subscribeLink').style.display = "table-cell";
      }
      else {
                for (var i=0; i < arrayLength; i++) {
          if(pianoInitData.data[i].granted == true){
            document.getElementById('myAccountLink').style.display = "table-cell";
            document.getElementById('subscribeLink').style.display = "none";
            break;
          }
          else{
            document.getElementById('subscribeLink').style.display = "table-cell";
          }
        }
      }
    }

        tp = window["tp"] || [];
    tp.push(['init', function() {
      if (!tp.user.isUserValid()) {
        document.getElementById('subscribeLink').style.display = "table-cell";
      }
    }]);

    
  </script>
      </div>
    </div>



      <script>
      // Mobile form submit when clicking icon
      $( "form > .input-search-icon" ).on("click", function(event) {
        var search_input = $('#search-popup input');
        if (search_input.val().length < 1) { search_input = $('#search-popup-mobile input'); }
        searchFormSubmit(search_input);
        event.preventDefault();
      });
      // Mobile Form
      $( "#search-popup-mobile form" ).submit(function( event ) {
        var search_input = $('#search-popup-mobile input');
        searchFormSubmit(search_input);
        event.preventDefault();
      });
          </script>
  </div>
</nav>

<script>
  function login() {
    window.parent.postMessage("login", "*");
  }

    document.getElementById('myAccountButtonMobile').style.display = "none";
  document.getElementById('loginButtonMobile').style.display = "block";

  // Add callback function to call stack for execution when piano init completes
  pianoInitRunStack.push(waitForPianoInitMainNavigation);

  function waitForPianoInitMainNavigation() {

    var arrayLength = pianoInitData.data.length;
    if(arrayLength == 0) {
      document.getElementById('myAccountButtonMobile').style.display = "block";
      document.getElementById('loginButtonMobile').style.display = "none";
    }
    for (var i=0; i < arrayLength; i++)
    {
      if(pianoInitData.data[i].granted == true) {
        document.getElementById('myAccountButtonMobile').style.display = "none";
        document.getElementById('loginButtonMobile').style.display = "none";
        break;
      }
      else {
        document.getElementById('myAccountButtonMobile').style.display = "block";
        document.getElementById('loginButtonMobile').style.display = "none";
      }
    }
    if (!tp.user.isUserValid()) {
      document.getElementById('loginButtonMobile').style.display = "block";
    }
  }

  
  $(document).ready(setSectionDropdownHeight);
  $(window).resize(setSectionDropdownHeight);

  observeStickyHeader = document.querySelector("#sticky-header");
  observer = new MutationObserver(setSectionDropdownHeight);
  observer.observe(observeStickyHeader, {attributes: true });

  function setSectionDropdownHeight() {
    // Determine normal dropdown-nav required height
    var bottomOfStickyHeader = $("#sticky-header").height() + $("#sticky-header").position().top;

    var dropdownNavHeight = 0;
    var dropdownNavListItems = $(".dropdown-nav").children("li");
    $.each(dropdownNavListItems, function(index, value){
      dropdownNavHeight += $(this).height();
    });

    if ($(window).height() < bottomOfStickyHeader + dropdownNavHeight && window.outerWidth > 1274) {
      $(".dropdown-list-item").height(dropdownNavHeight);
      $(".dropdown-nav").css({ margin: 0, "overflow-y": "auto" });
      $(".dropdown-nav").height($(window).height() - bottomOfStickyHeader);
    } else {
      $(".dropdown-list-item").height("auto");
      $(".dropdown-nav").css("overflow","hidden");
      $(".dropdown-nav").height("auto");
    }

    // if the menu-btn is checked, click it to remove the border on the big desktop view
    if ($(".menu-btn").is(":checked") === true && window.outerWidth > 1274) {
      $(".menu-btn").click();
    }
  }
</script>
  </div>

    <script>
    document.addEventListener('DOMContentLoaded', function() {
      var sectionPage = null;
      var section = null;
      var mainNav = $('#sticky-header'),
      mainLogo = $('#bigLogoImage'),
      core = $('.container').eq(0),
      mainNavScrolled = 'sticky',
      mainNavHeight, header;

      $(window).resize(function() {
        mainNavHeight = mainNav.outerHeight();
        header = $('.site-masthead-container').outerHeight();
      })

      .resize().scroll(function() {
        //check if window is wide enough to display the bigLogoImage
        if ($(document).width() > 1275){
          //if on an account/paywall page, add 'sticky' class and adjust z-index of mainNav
          if (['my-account-index','my-account-benefits','my-account-e-paper','my-account-newsletter','my-account-subscriptions','activate','subscribe','help-center','password-reset', 'promos'].indexOf(sectionPage) >= 0) {
            document.getElementById('topNav').style.border='none';
            mainNav.addClass(mainNavScrolled);
            mainNav.css('z-index', 300000); //adjusting z-index to keep mainNav below piano modals
          }
          else if (section == "bison") {
            document.getElementById('topNav').style.border='none';
            mainNav.addClass(mainNavScrolled);
            mainNav.css('z-index', 300000); //adjusting z-index to keep mainNav below piano modals
            core.css('margin-top', mainNavHeight);
          }
           else if ($(this).scrollTop() > header) {
            mainNav.addClass(mainNavScrolled);
            core.css('margin-top', mainNavHeight);
          } else {
            mainNav.removeClass(mainNavScrolled);
            core.attr('style', '');
          }
        }
      })
      .on('load', function() {
        $(this).scroll();
      })
    });
  </script>
</header>
    
          <div class="container">
                              <!---google data layer var -->
<script>
dataLayer.push({ 'page_category': 'story' });
</script>
<div class="trending-news-ticker">
  </div>

<div class="article-story-page-container">
  <div id="bannerOne">
    <div id="banner-1">
  <script>
    googletag.cmd.push(function() {
      googletag.display('banner-1');
    });
    $(window).ready(function() {
      refreshBid('banner-1', 'banner_1');
    });
  </script>
</div>
  </div>

    
  <div id="article-section-header"><section>
    <div id="article-header">

      <div class="article-header-title">
        <a href="/sports/" class="link section-label allCaps">Sports</a><h1 class="article-headline">
            Top-10 Republican Eagle Sports Stories: Plenty of success at state
    </h1><div class="article-leadtext"></div>  
        
  
        
  <div class="light-grey byline">
    

Written By:
<span id="noLink" class="ttu">RE Sports</span> |
    


    
      

    <time class="timestamp">
        <meta itemprop="datePublished" content="2020-01-02T21:22:56.000Z">

        Jan 2nd 2020 - 3pm.

    </time>
      </div>
</div>

                          

    </div>
  </section>

</div>

  <div id="article-section-body">
    <div id="top-social-share"><ul class="social-sharing">
  <div class="addthis_inline_share_toolbox"></div>
  <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ec67b5ab5cb344"></script>
</ul>
</div>
                  
              <div class="article-header-media">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847313-oqzy3x-Top-10-Randolph-Section-Baseball.jpg/alternates/BASE_LANDSCAPE/Top-10%20Randolph%20Section%20Baseball.jpg" alt="Randolph celebrates the program&#039;s first section title after beating Goodhue. Martin Schlegel / RiverTown Multimedia" width="" srcset=""/>
            </div> 
	<div class="caption">Randolph celebrates the program&#039;s first section title after beating Goodhue. Martin Schlegel / RiverTown Multimedia<span class="credit"></span></div>
      </div>
    
        
    <div class="article-body"><div class="main-body">
      <div class="first-p">                        <p>The Pierce and Goodhue County area sports teams collectively had another successful year in 2019. These are some of the top moments of the year.</p></div>    <div class="p402_premium"><div id="article-mobile-container">
  <div id="article-mobile">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-mobile');
      });
      // Pass in the slot for the ad
      $(window).on("load", function() {
        $('#article-mobile-container').lazyload('article-mobile');
      });
    </script>
  </div>
</div>
                        <p><br></br></p>                            <h3><b>Three Kenyon-Wanamingo wrestlers win state titles</b></h3>                            <p>Seniors Jerron Matson, Seth Brossard and Tyler Craig all went out on top. The three led Kenyon-Wanamingo to a second-place finish in the team tournament, then days later each won a state title in their respective weight classes.</p>                            <p>First was Matson at 120 pounds, who earlier in the season tore his meniscus and opted for surgery. Five weeks after the initial injury, he was back for the section quarterfinals and continued to wrestle through into state.</p>    <div class="in-article-container"><div id="in-article">
  <script>
    googletag.cmd.push(function() {
      googletag.display('in-article');
    });
    $(window).ready(function() {
      refreshBid('in-article', 'in_article');
    });
  </script>
</div></div>
        <div id="live-and-newsletter"  class="p402_hide">
      
            <div id="newsletterSignup">
          


<section class="marketing-newsletter-image">
  <a href="javascript:newsletter();">
    <img class="imgDesktop" src="https://static.forumcomm.com/images/300x50/newsletter_signup.png" />
  </a>
</section>

<script>
  function newsletter(){
    window.parent.postMessage("click", "*");
  }
</script>
      </div>
    </div>                        <p>“I didn’t know how he would respond,” K-W head coach Matt Ryan said regarding how Matson would hold up in the state meet. “Jeron handled it well.”</p>                            <p>At 152 pounds, Brossard took control in the second period and dominated in the third for the win. Ryan said Brossard had put in lots of work to be able to make a bid for a title that had eluded him in previous years.</p>                            <p>“He did everything right,” Ryan said of Brossard’s year as a whole. “He did a great job of fending off the desperation (in the title match) and set a good pace throughout.”</p>                            <p>Wrestling in the following match was Tyler Ryan. He had the same surgery as Matson much earlier in the season to repair a meniscus that tore for a second time.</p>                            <p>Matt Ryan wasn’t sure what to expect of Tyler in the state title at 160 pounds. In a back-and-forth match, Tyler earned a takedown in the final 10 seconds of the third period to put him ahead by a point. It wound up being the winning takedown and it came as a big surprise to Matt.</p>    <div id="in-article-2-container">
  <div id="in-article-2">
    <script>
      googletag.cmd.push(function() {
          googletag.display('in-article-2');
      });
      // Pass in the slot name for the ad
      $(window).on("load", function() {
        $("#in-article-2-container").lazyload('in_article_2');
      });
    </script>
  </div>
</div>
<div id="article-mobile-2-container">
  <div id="article-mobile-2">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-mobile-2');
      });
      // Pass in the slot name for the ad
      $(window).on("load", function() {
        $("#article-mobile-2-container").lazyload('article-mobile-2');
      });
    </script>
  </div>
</div>
                        <p>“The last 10 seconds have changed how we feel today and how we’ll feel in the next five years,” Matt said.</p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847308-7ib36y-Top-10-K-W-Jeron-Matson.jpg/alternates/BASE_LANDSCAPE/Top-10%20K-W%20Jeron%20Matson.jpg" alt="Jerron Matson of Kenyon-Wanamingo (left) wrestles in the 120-pound state title match. Martin Schlegel / RiverTown Multimedia" width="1140" srcset="https://www.rivertowns.net/incoming/4847308-7ib36y-Top-10-K-W-Jeron-Matson.jpg/alternates/LANDSCAPE_480/Top-10%20K-W%20Jeron%20Matson.jpg 480w, https://www.rivertowns.net/incoming/4847308-7ib36y-Top-10-K-W-Jeron-Matson.jpg/alternates/LANDSCAPE_560/Top-10%20K-W%20Jeron%20Matson.jpg 560w, https://www.rivertowns.net/incoming/4847308-7ib36y-Top-10-K-W-Jeron-Matson.jpg/alternates/LANDSCAPE_768/Top-10%20K-W%20Jeron%20Matson.jpg 768w, https://www.rivertowns.net/incoming/4847308-7ib36y-Top-10-K-W-Jeron-Matson.jpg/alternates/BASE_LANDSCAPE/Top-10%20K-W%20Jeron%20Matson.jpg 1140w, "/>
            </div> 
	<div class="caption">Jerron Matson of Kenyon-Wanamingo (left) wrestles in the 120-pound state title match. Martin Schlegel / RiverTown Multimedia<span class="credit"></span></div>
</div>
</p>                            <h3><b>Ten Pierce County wrestlers compete at individual state tournament</b></h3>                            <p>Ten Pierce County wrestlers qualified for the individual state tournament last February. Ellsworth had eight of those qualifiers: Carter Huppert, Charlie Stuhl, Jared Lansing, Sawyer Hamilton, Logan Melstrom, Logan Peterson, Cedric Kosnopfal and Jared Toenjes. From Prescott there was Joe Schulte and Kenny Fesenmaier represented Spring Valley/Elmwood.</p>                            <p>Stuhl (132-pounds) and Lansing (145) were the top finishers as both finished third in Division 2. Stuhl beat Edgerton’s Cole Bavery by a 4-0 decision in the third-place match while Lansing beat Zach Boehnlein of Chilton/Hilbert by an 11-0 major decision, his second win over Boehnlein of the tournament.</p>    <div id="in-article-3-container">
  <div id="in-article-3">
    <script>
      googletag.cmd.push(function() {
          googletag.display('in-article-3');
      });
      // Pass in the slot name for the ad
      $(window).on("load", function() {
        $("#in-article-3-container").lazyload('in_article_3');
      });
    </script>
  </div>
</div>
<div id="article-mobile-3-container">
  <div id="article-mobile-3">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-mobile-3');
      });
      // Pass in the slot name for the ad
      $(window).on("load", function() {
        $("#article-mobile-3-container").lazyload('article-mobile-3');
      });
    </script>
  </div>
</div>
                        <p>Toenjes (170) and Peterson (285) both took fifth for Ellsworth while Melstrom (195) finished sixth. Toenjes beat Tanner Goeman of Kewaskum by a 9-3 decision, second win over Goeman in just a few days. Peterson was up 12-0 in his fifth-place match before he pinned Belleville’s Daniel Enloe in the third period. Melstrom lost his fifth-place match to Belmont’s Will Schaefer by fall. Fesenmaier finished sixth for SVE after he lost to Fennimore’s Aaron Ragel by a 4-2 decision and finished his senior year with a record of 32-13. </p>                            <p>Hamilton (152) won his first match by a 5-2 decision over Gaven Lisowe of Chilton/Hilbert but then dropped his next two matches. Kosnopfal (160) lost his first match to Colton Worachek of Luxemburg-Casco by a 4-2 decision and was eliminated. For Prescott, Schulte (220) lost his first two matches at state. </p>                            <p>Of the eight wrestlers who competed at state last year, Huppert, Stuhl, Peterson and Schulte all look to return this year.</p>                            <p><br></br></p>                            <h3><b>Ellsworth Panthers wrestling takes second at team state</b></h3>                            <p>The Ellsworth wrestling team won their 14th-straight section championship last February and returned to the Division 2 team state tournament for the 14th time as well. It was also their record-tying 18th trip to team state overall. Ellsworth went on to make the state finals as the top seed but fell to No. 2 Freedom 35-16 to take second.</p>                            <p>The Panthers cruised through Section A with blowout wins over Medford (53-15) in the semifinals and Spooner/Webster 51-18 in the final. Once at state, Ellsworth opened up by beating No. 4 Wisconsin Lutheran 50-18 in the semifinals. Wisconsin Lutheran took just four weight classes, one of which was a forfeit. Charlie Stuhl, Jared Lansing, Sawyer Hamilton, Cedric Kosnopfal, Logan Melstrom and Logan Peterson all got pins for the Panthers in the remaining 11 matches to cruise to victory.</p>                            <p>The championship dual got off to a rough start for Ellsworth, which dropped the first three weights and trailed 9-0 until Stuhl won by major decision at 132-pounds. Lansing (145) and Hamilton (152) also collected major-decision wins to put the Panthers into a 12-12 tie with Freedom. Kosnopfal (170) put the Panthers ahead 16-15 with another major decision but from there it was all downhill for Ellsworth. Freedom took the final five matches to secure the win. </p>                            <p>Head coach Mark Matzek said at the time that his team had been sloppy in their win over Wisconsin Lutheran and that cost them against Freedom.</p>                            <p>“We didn&#039;t show up, but that&#039;s ultimately my fault,&quot; Matzek said. &quot;I&#039;ve got to find out why didn&#039;t we. We showed up at the Clash; we wrestled better against Simley. Sectionals, you know, what was it? That&#039;s something for me to figure out.”</p>                            <p>Co-captains Lansing and Stuhl agreed with their head coach.</p>                            <p>&quot;I could tell from a while earlier that we weren&#039;t in it like we should have been,&quot; Lansing said. &quot;The feeling just wasn&#039;t right.&quot;</p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847353-swg2zl-Ellsworth-wrestling-2.jpg/alternates/BASE_LANDSCAPE/Ellsworth%20wrestling%202.jpg" alt="The Ellsworth Panthers wrestling team hoisted a WIAA Division 2 sectional championship trophy for the 14th year in a row in 2019. File photo" width="1140" srcset="https://www.rivertowns.net/incoming/4847353-swg2zl-Ellsworth-wrestling-2.jpg/alternates/LANDSCAPE_480/Ellsworth%20wrestling%202.jpg 480w, https://www.rivertowns.net/incoming/4847353-swg2zl-Ellsworth-wrestling-2.jpg/alternates/LANDSCAPE_560/Ellsworth%20wrestling%202.jpg 560w, https://www.rivertowns.net/incoming/4847353-swg2zl-Ellsworth-wrestling-2.jpg/alternates/LANDSCAPE_768/Ellsworth%20wrestling%202.jpg 768w, https://www.rivertowns.net/incoming/4847353-swg2zl-Ellsworth-wrestling-2.jpg/alternates/BASE_LANDSCAPE/Ellsworth%20wrestling%202.jpg 1140w, "/>
            </div> 
	<div class="caption">The Ellsworth Panthers wrestling team hoisted a WIAA Division 2 sectional championship trophy for the 14th year in a row in 2019. File photo<span class="credit"></span></div>
</div>
</p>                            <h3><b>Lake City boys basketball earn third at state</b></h3>                            <p>After getting bowled over by powerhouse Minnehaha Academy, the Lake City boys’ basketball team responded with a hard-fought 51-47 win over Perham in the third-place game at state. The win was the Tigers’ 28th of the season. Lake City head coach Greg Berge pointed out after the game that the Tigers only three losses in a 28-3 season were to teams with a top-10 player in the state (Breck, Rochester John Marshall, Minnehaha Academy).</p>                            <p>“That&#039;s a phenomenal season,” Berge said of the wins and losses. “I think we&#039;ve won more games than any team in the history of Lake City basketball. I told the guys how special this season was. We&#039;re fortunate, we have four starters coming back.”</p>                            <p>The win over Perham showed how exhausted the two teams were and how badly each wanted to end the season with a win.</p>                            <p>“I told the guys this game is about your head and your heart,” Berge said. “You have to be mentally tough in your head today because you&#039;re going to get tired and you have to overcome that mentally. You have to have heart. It&#039;s the last game of your season. I thought they did it.”</p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847310-qjuopg-Top-10-Lake-City-BB.jpg/alternates/BASE_LANDSCAPE/Top-10%20Lake%20City%20BB.jpg" alt="The Lake City boys basketball team celebrates their win in the third-place game over Perham. Martin Schlegel / RiverTown Multimedia" width="1140" srcset="https://www.rivertowns.net/incoming/4847310-qjuopg-Top-10-Lake-City-BB.jpg/alternates/LANDSCAPE_480/Top-10%20Lake%20City%20BB.jpg 480w, https://www.rivertowns.net/incoming/4847310-qjuopg-Top-10-Lake-City-BB.jpg/alternates/LANDSCAPE_560/Top-10%20Lake%20City%20BB.jpg 560w, https://www.rivertowns.net/incoming/4847310-qjuopg-Top-10-Lake-City-BB.jpg/alternates/LANDSCAPE_768/Top-10%20Lake%20City%20BB.jpg 768w, https://www.rivertowns.net/incoming/4847310-qjuopg-Top-10-Lake-City-BB.jpg/alternates/BASE_LANDSCAPE/Top-10%20Lake%20City%20BB.jpg 1140w, "/>
            </div> 
	<div class="caption">The Lake City boys basketball team celebrates their win in the third-place game over Perham. Martin Schlegel / RiverTown Multimedia<span class="credit"></span></div>
</div>
</p>                            <h3><b>Red Wing boys’ and girls’ golf enjoy state success</b></h3>                            <p>Five hours after Winger Cecil Belisle won his second boys’ golf state title in three years, Sophia Yoemans won her third consecutive girls’ state title. The two became the fifth pair of golfers in state high school history to win an individual state title from the same school. The last time a boys’ and girls’ golfer from the same school won their respective title was, conveniently, Belisle and Yoemans in 2017.</p>                            <p>Red Wing boys’ head coach Nate Gale said he knew Belisle could rebound from a triple-bogey on the first hole of the first round and Belisle did just that. In the second round on the 13th hole, Belisle went ahead with a birdie and played even the final five holes to capture the state title.</p>                            <p>Yoemans finished ahead of teammate Leah Herzog for her third consecutive state title. Yoemans and Herzog didn’t know it until the final tally on the big scorecard outside the clubhouse was updated. They had led the Wingers to a team title, winning a single stroke.</p>                            <p>Along with Yoemans and Herzog, Ashten Chandler, Grace Dube, Sydney Flack and Ava Bremseth shared the excitement of winning the team title.</p>                            <p>“What a week we’ve had,” said Red Wing girls’ head coach Mark Herzog after the trophy presentations. “They’ve all been different people too. A state champion, then another is Ms. Minnesota, then the team title. There is something for everyone to celebrate, and they get to celebrate with their team, too.”</p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847315-yavhs-Top-10-Red-Wing-Golf.jpg/alternates/BASE_LANDSCAPE/Top-10%20Red%20Wing%20Golf.jpg" alt="Red Wing&#039;s Cecil Belisle (left) and head coach Nate Gale (right) pose for a picture after Belisle won the Class AA state title. Martin Schlegel / RiverTown Multimedia" width="1140" srcset="https://www.rivertowns.net/incoming/4847315-yavhs-Top-10-Red-Wing-Golf.jpg/alternates/LANDSCAPE_480/Top-10%20Red%20Wing%20Golf.jpg 480w, https://www.rivertowns.net/incoming/4847315-yavhs-Top-10-Red-Wing-Golf.jpg/alternates/LANDSCAPE_560/Top-10%20Red%20Wing%20Golf.jpg 560w, https://www.rivertowns.net/incoming/4847315-yavhs-Top-10-Red-Wing-Golf.jpg/alternates/LANDSCAPE_768/Top-10%20Red%20Wing%20Golf.jpg 768w, https://www.rivertowns.net/incoming/4847315-yavhs-Top-10-Red-Wing-Golf.jpg/alternates/BASE_LANDSCAPE/Top-10%20Red%20Wing%20Golf.jpg 1140w, "/>
            </div> 
	<div class="caption">Red Wing&#039;s Cecil Belisle (left) and head coach Nate Gale (right) pose for a picture after Belisle won the Class AA state title. Martin Schlegel / RiverTown Multimedia<span class="credit"></span></div>
</div>
</p>                            <h3><b>Prescott girls’ golf, freshman Ava Salay take second at state</b></h3>                            <p>A year after finishing eighth in their section meet, the Prescott Cardinals girls’ golf team put together a historic season after advancing to the Division 2 state meet for the first time in program history. Prescott advanced to the section meet for just the third time in team history in 2018, but the Cardinals exploded in 2019 and racked up the accolades on their way to the state tournament. They finished second in the Middle Border Conference behind New Richmond and broke the Tigers’ five-year conference winning streak.</p>                            <p>They had four players named All-Middle Border Conference – Alexis Fredericks, Jessica Heinsch, Liz Rohl and Ava Salay – while Salay, who is a freshman, was the MBC Player of the Year after earning medalist honors in all 10 conference meets.</p>                            <p>The Cardinals won a regional championship on the way to the section tournament, where as a team they shot a 390 at Edgewood Sacred Heart to capture a section championship and their first trip to state. Over two days at University Ridge, Prescott shot a team score of 773 to finish second behind state-champion Edgewood (702) and 17 strokes ahead of MBC rival St. Croix Central, who finished third. </p>                            <p>“Overall I was thrilled with the outcome for our team,” Prescott’s head coach Chad Salay said. “Most of our girls have only one to two years of tournament experience — let alone state tournament experience — so for them to handle the pressure of a state tournament and perform as well as they did as a team, we are thrilled.”</p>                            <p>Ava Salay finished second as an individual with a score of 166, 91 on day one and 85 on day two, eight strokes behind the champion and one ahead of the third-place finisher.</p>                            <p>“Still, for (Ava) to pull out a runner-up against a very solid field of state golfers that were giving her a real run that second day, she has a lot to be proud of and she gained some invaluable experience,” coach Salay said. “I have a pretty good source that says she will come back pretty hungry next season.”</p>                            <p>Prescott returns four of their five varsity players next year, all four of whom were underclassmen this year. However, they do lose Fredericks, who was a rock for the Cardinals throughout her career during the seasons leading up to 2019. </p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847354-135reo-Prescott-girls-golf-1.JPG/alternates/BASE_LANDSCAPE/Prescott%20girls%20golf%201.JPG" alt="The Prescott girls&#039; golf team earned a second-place finish at the WIAA Division 2 Girls&#039; Golf State Championships in October. Photo courtesy of Chad Salay" width="1140" srcset="https://www.rivertowns.net/incoming/4847354-135reo-Prescott-girls-golf-1.JPG/alternates/LANDSCAPE_480/Prescott%20girls%20golf%201.JPG 480w, https://www.rivertowns.net/incoming/4847354-135reo-Prescott-girls-golf-1.JPG/alternates/LANDSCAPE_560/Prescott%20girls%20golf%201.JPG 560w, https://www.rivertowns.net/incoming/4847354-135reo-Prescott-girls-golf-1.JPG/alternates/LANDSCAPE_768/Prescott%20girls%20golf%201.JPG 768w, https://www.rivertowns.net/incoming/4847354-135reo-Prescott-girls-golf-1.JPG/alternates/BASE_LANDSCAPE/Prescott%20girls%20golf%201.JPG 1140w, "/>
            </div> 
	<div class="caption">The Prescott girls&#039; golf team earned a second-place finish at the WIAA Division 2 Girls&#039; Golf State Championships in October. Photo courtesy of Chad Salay<span class="credit"></span></div>
</div>
</p>                            <h3><b>Ellsworth, Prescott softball teams qualify for state </b></h3>                            <p>A pair of Pierce County and Middle Border Conference teams qualified for their respective state tournaments this past spring. After having high hopes for the 2018 season that didn’t quite turn out, the Ellsworth softball team advanced to Division 2 state tournament with a talented roster, most of which returns for the 2020 season. Meanwhile, Prescott softball went to the Division 3 state tournament for the second year in a row.</p>                            <p>The Cardinals beat the Bloomer Blackhawks 6-4 in the section championship game while Ellsworth beat Merrill 4-1 to advance to state. Prescott went on to face Poynette in the state semifinals, which had a 40-plus game winning streak. The Panthers drew the No. 2-seeded Seymour Thunder.</p>                            <p>Both teams lost in their semifinal games to end their state runs, though both Poynette and Seymour went on to win their respective state championships. Seymour took a 3-0 lead over Ellsworth in the third inning and made it 4-0 in the top of the fourth. Claire Kummer was responsible for both of the Panthers’ runs – she scored on an error in the bottom of the fourth and then doubled and scored on a Kaitlyn Nugent RBI-single – but they could not complete the comeback and lost 4-2. Ellsworth finished the season with a 24-3 record and returns almost the entire team in 2020.</p>                            <p>Prescott was shutout by Poynette 7-0 in their semifinal match. The Cardinals managed just two hits as Poynette pitcher Casey Fountain notched 14 strikeouts and Prescott had just three total base runners for the game. </p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847374-71z20n-Prescott-softball.jpg.jfif/alternates/BASE_LANDSCAPE/Prescott%20softball.jpg.jfif" alt="The Prescott Cardinals advanced to the WIAA Division 3 State Softball Tournament for the second year in a row this past spring. Photo courtesy of Chad Lenz" width="1140" srcset="https://www.rivertowns.net/incoming/4847374-71z20n-Prescott-softball.jpg.jfif/alternates/LANDSCAPE_480/Prescott%20softball.jpg.jfif 480w, https://www.rivertowns.net/incoming/4847374-71z20n-Prescott-softball.jpg.jfif/alternates/LANDSCAPE_560/Prescott%20softball.jpg.jfif 560w, https://www.rivertowns.net/incoming/4847374-71z20n-Prescott-softball.jpg.jfif/alternates/LANDSCAPE_768/Prescott%20softball.jpg.jfif 768w, https://www.rivertowns.net/incoming/4847374-71z20n-Prescott-softball.jpg.jfif/alternates/BASE_LANDSCAPE/Prescott%20softball.jpg.jfif 1140w, "/>
            </div> 
	<div class="caption">The Prescott Cardinals advanced to the WIAA Division 3 State Softball Tournament for the second year in a row this past spring. Photo courtesy of Chad Lenz<span class="credit"></span></div>
</div>
</p>                            <h3><b>Randolph baseball leaves first state appearance emotional</b></h3>                            <p>In the program’s history, Randolph had never made it to the state tournament in baseball. In 2018, the Rockets needed just one win in the section finals to advance, but fell in back-to-back games.</p>                            <p>Tired of collecting red ribbons, the Rockets took care of Goodhue in the 2019 section finals and secured its first section title and first trip to the state tournament.</p>                            <p>In the state tournament, the Rockets lost 10-0 to Kerkhoven-Murdock-Sunburg, beat Sebeka 11-1, then lost in the consolation championship 16-5 to Hayfield.</p>                            <p>The Rockets weren’t given any medals nor any trophies to signify a trip to state. What the team did get was a chance to make some memories. The players enjoyed their stay in the Cities. The parents were able to applaud the efforts of the seniors one final time as they were individually pulled from the game against Hayfield in the middle of the top of the sixth. Maybe more importantly, the community will remember the 2019 Rockets for a long time.</p>                            <p>“On the boys&#039; side there has only been one other team to get to that point,” said Randolph head coach Chris Stanton. “(This team) showed that they can do it. Credit to our softball team, when they broke through last year it helped the boys have that mentality of we can do this too. They all shared a common goal. It&#039;s going to be one I&#039;ll never forget.”</p>                            <p>Stanton told his players one last thing before letting the seniors leave the final postgame team meeting.</p>                            <p>“In Randolph, you&#039;ll be remembered forever,” Stanton said.. “We talk about the 1979 football team forever. They are going to talk about the 2019 (baseball) team for a long time.”</p>                            <p>For the seniors, it was about leaving a mark.</p>                            <p>“We always get that, ‘Where’s Randolph?’ thing,” said senior Joey Erickson. “You want people to stop saying that and we tried to do that (by playing in the tournament).”</p>                            <p><br></br></p>                            <h3><b>Cannon Falls football wins consecutive section titles</b></h3>                            <p>The No. 9-ranked Cannon Falls football team advanced to its third state tournament with a 40-13 win over Breck in the Section 4AAA championship.</p>                            <p>“This is only the third Cannon Falls team to ever make it to state and obviously we&#039;re going to celebrate,” said Cannon Falls head coach Dan Meyers, “but we will probably wait until the season is over to really celebrate what&#039;s going on because we have another game next week. We told our guys to have fun and enjoy this one ... But we have to come back Monday. We would love to keep going. From here on it keeps getting bigger and bigger, and more fun.”</p>                            <p>Breck running back Derek Turner muffed the opening kickoff and the Bombers recovered, setting up their first score of the game. The momentum remained on the Bomber sideline as the Mustangs had no answer for the Bomber runners and defensive line.</p>                            <p>By the end of the first half, the Bombers led by a comfortable 34-7 margin.</p>                            <p>“We have a lot of games like (this one) where we&#039;ve been up big at halftime and been able to use some other guys,” Meyers said, “which is nice over the course of a long season to get some rest for the starters. I would attribute it to our guys being really diligent at practice.”</p>                            <p>2019 marked the third trip to state for Cannon Falls. The first came back in 1996.</p>                            <p>
  

<div class="inline-element">
                   
      <div class="image">   
          <img src="https://www.rivertowns.net/incoming/4847332-x69mc3-Top-10-CF-Team-Sect-Final.jpg/alternates/BASE_LANDSCAPE/Top-10%20CF%20Team%20Sect%20Final.jpg" alt="Cannon Falls poses with their 2019 Section 4AAA trophy. Martin Schlegel / RiverTown Multimedia" width="1140" srcset="https://www.rivertowns.net/incoming/4847332-x69mc3-Top-10-CF-Team-Sect-Final.jpg/alternates/LANDSCAPE_480/Top-10%20CF%20Team%20Sect%20Final.jpg 480w, https://www.rivertowns.net/incoming/4847332-x69mc3-Top-10-CF-Team-Sect-Final.jpg/alternates/LANDSCAPE_560/Top-10%20CF%20Team%20Sect%20Final.jpg 560w, https://www.rivertowns.net/incoming/4847332-x69mc3-Top-10-CF-Team-Sect-Final.jpg/alternates/LANDSCAPE_768/Top-10%20CF%20Team%20Sect%20Final.jpg 768w, https://www.rivertowns.net/incoming/4847332-x69mc3-Top-10-CF-Team-Sect-Final.jpg/alternates/BASE_LANDSCAPE/Top-10%20CF%20Team%20Sect%20Final.jpg 1140w, "/>
            </div> 
	<div class="caption">Cannon Falls poses with their 2019 Section 4AAA trophy. Martin Schlegel / RiverTown Multimedia<span class="credit"></span></div>
</div>
</p>                            <h3><b>Spring Valley football reaches Level 3 playoffs</b></h3>                            <p>The Spring Valley Cardinals finally broke through and made it to the Level 3 playoffs this fall after being unable to advance past Level 2 the previous three years. A huge part of that breakthrough were the efforts of the senior class, led by quarterback Aaron Borgerding, which took the Cardinals to another level.</p>                            <p>“Our sophomore year, we weren’t really sure how we were going to impact the game,” Borgerding said. “Our senior class helped change the culture of our team. Our comradery and what we did together … This group of guys is just so fun to be with. We just play for each other. We don’t really play against the other team. We play to better ourselves and just have fun with one another.”</p>                            <p>Spring Valley went 8-1 during the regular season and finished second in the Dunn-St.Croix Conference (5-1), a game behind champion Mondovi who the Cardinals lost to by three points in week 8. They then blew out DSC-opponent Durand 34-14 in the first round of the playoffs and Unity 47-20 in the second round. This setup a Level 3-matchup against Regis, who Spring Valley had lost to in the playoffs the previous two years.</p>                            <p>Heading into the game, Regis was undefeated and averaging over 45 points per game. However, Spring Valley held the Ramblers to just eight first-half points and the game was tied 8-8 at halftime. The Cardinals blocked a Regis punt for a safety and Borgerding scored on a 28-yard touchdown run. In the second half, the Ramblers steadily pulled away to a 29-8 win. It was the fewest points Regis was held to all season up to that point. </p>                            <p>“I felt like we did some things well when this senior group was younger, but I feel like this senior group really took control of the culture and took it to another level that we weren’t at before,” said Spring Valley head coach Ryan Kapping said. “Putting in the weight room as well as just supporting each other and hanging out with each other and really having that genuine love for each other, they’ve set a really good year for next year’s seniors.”</p>                            <p><br></br></p>                            <p><i>Note: These Top-10 stories are in loose chronological order by season and not by numerical ranking.</i></p>    </div><script type="text/javascript">
            tp = window["tp"] || [];
      tp.push(['init', function() {
        if (!tp.user.isUserValid()) {
          try {
            _402_Show();
          } catch(e) {}
        }
      }]);
            pianoInitRunStack.push(waitForPianoInitSurvery);
      function waitForPianoInitSurvery() {
        if(pianoInitData.data.length == 0){
          try {
            _402_Show();
          } catch(e) {}
        }
      }
    </script></div>
</div>
            
    
                      
                
        
                                                          
                              
                            
              
                
        
                                                          
                              
                            
       <div id="bottom-social-share"><ul class="social-sharing">
  <div class="addthis_inline_share_toolbox"></div>
  <script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ec67b5ab5cb344"></script>
</ul>
</div>
    <div id="marketing-1-mobile-container">
  <div id="marketing-1-mobile">
    <script>
      googletag.cmd.push(function() {
        googletag.display('marketing-1-mobile');
      });
      $(window).on("load", function() {
        $('#marketing-1-mobile-container').lazyload('marketing-1-mobile');
      });
    </script>
  </div>
</div>
  </div>

  <div id="article-section-related">
    <div class="related-media"><div class="fcc-slider fccslider article-slider">
  <button class='prev'>
    <img src='/theme/images/fcc-slider/arrow-back.png'>
  </button>     
    <div class="individual-slide">
      <img src="https://www.rivertowns.net/incoming/4847514-ejbh84-RW-Golf-Sophia-Yoemans.jpg/alternates/LANDSCAPE_768/RW%20Golf%20-%20Sophia%20Yoemans.jpg" alt="RiverTowns">
      <div class="carousel-info">
        <div id="counter"><span>1</span> / 2</div>
        <div class="caption">Red Wing&#039;s Sophia Yoemans reacts after sinking her final put of the second round at the State Tournament. Yoemans won her third state title and helped lead the Wingers to a team title. Martin Schlegel / RiverTown Multimedia</div>
        <div class="credit"></div>
      </div>
    </div>
           
    <div class="individual-slide">
      <img src="https://www.rivertowns.net/incoming/4847351-k38791-Top-10-K-W-Tyler-Ryan.jpg/alternates/LANDSCAPE_768/Top-10%20K-W%20Tyler%20Ryan.jpg" alt="RiverTowns">
      <div class="carousel-info">
        <div id="counter"><span>2</span> / 2</div>
        <div class="caption">Tyler Ryan of Kenyon-Wanamingo celebrates his last second victory at in the 160-pound state title. Martin Schlegel / RiverTown Multimedia</div>
        <div class="credit"></div>
      </div>
    </div>
        <button class='next'>
    <img src='/theme/images/fcc-slider/arrow-next.png'>
  </button>
</div>

<script>
  $.fcc_slider('.fccslider');
</script></div>
    <div class = "article-tag-list">
        <h3>Related Topics</h3>
  <div class="tag-item">
      <a href="/tags/REPUBLICAN_EAGLE" class="tag-link">REPUBLICAN EAGLE</a>
  </div>
<div class="tag-item">
      <a href="/tags/red_wing_wingers" class="tag-link">RED WING WINGERS</a>
  </div>
<div class="tag-item">
      <a href="/tags/cannon_falls_bombers" class="tag-link">CANNON FALLS BOMBERS</a>
  </div>
<div class="tag-item">
      <a href="/tags/lake_city_tigers" class="tag-link">LAKE CITY TIGERS</a>
  </div>
<div class="tag-item">
      <a href="/tags/randolph_rockets" class="tag-link">RANDOLPH ROCKETS</a>
  </div>
<div class="tag-item">
      <a href="/tags/ellsworth_panthers" class="tag-link">ELLSWORTH PANTHERS</a>
  </div>
<div class="tag-item">
      <a href="/tags/prescott_cardinals" class="tag-link">PRESCOTT CARDINALS</a>
  </div>
    </div>
    <div class="mobile-origami">  <div id="origami-ad-container"></div>
  <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="e73a44c7-bde3-463f-9611-d6f0e0a819c7"></script>
</div>
  </div>

  <div id="article-section-footer"><section class="article-footer">
<div id="marketing-1-footer">
</div>      <h1 class="section-header">Suggested Articles</h1>
<section class="related-content">
    <div class="section-three-across">
                        
                        
                                                                
                        
                                                  
            <article itemscope itemtype="http://schema.org/Article">
<div class="article-teaser-container">
  <div class="article-teaser-content">
  <div class="article-teaser-image">            <a href="/sports/hockey/4847885-Western-Wisconsin-Stars-reach-title-game-in-Herb-Brooks-Classic" title="Western Wisconsin Stars reach title game in Herb Brooks Classic">
      <div class="placeholder">
        <div class="image">
  <img src="https://static.forumcomm.com/images/placeholder/rivertowns.svg"  onError="this.onerror=null;this.src='/theme/images/logos/placeholder/rivertowns.svg';" alt="rivertowns logo">
</div>
      </div>
    </a>
  

  </div> 
  <div class="article-teaser">
          <div class="section-time">
      <a href="/sports/hockey/" class="link section-label allCaps">Hockey</a>    


    
      

    <time class="timestamp">
        <meta itemprop="datePublished" content="2020-01-02T23:46:48.000Z">

        Jan 2nd 2020 - 5pm

    </time>
  </div>
      <h3 class="article-headline"><a href="/sports/hockey/4847885-Western-Wisconsin-Stars-reach-title-game-in-Herb-Brooks-Classic">Western Wisconsin Stars reach title game in Herb Brooks Classic</a></h3>
      </div>
</div>
</div>
</article>
                                                                    
            <div id="nativo-sponsored-content"></div>
    </div>
</section>
  </section>
</div>

  <div id="aside">
    <div class="sidebar tablet-1"><div id="article-tablet-container">
  <div id="article-tablet">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-tablet');
      });
      // Pass in the slot for the ad
      $(window).on("load", function() {
        $('#article-tablet-container').lazyload('article-tablet');
      });
    </script>
  </div>
</div>
</div>
    <div class="sidebar jobs">  <div id="jobsHQ-hotjobs-desktop" class="jobsWidget"></div>
  <div id="jobsHQ-hotjobs-list" class="jobsWidget"></div>
  <div id="jobsHQ-hotjobs-single" class="jobsWidget"></div>
  <script async src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
  <script>
    window.onload = function () {
      if ($(window).width() > 1060) {
        loadJobsHQ.desktop('jobsHQ-hotjobs-desktop', 28);
      }
      else if ($(window).width() > 767 && ($('.section-page-container').length > 0 || $('.article-story-page-container').length > 0) ) {
        loadJobsHQ.desktop('jobsHQ-hotjobs-desktop', 28);
      }
      else if ($(window).width() > 767) {
        loadJobsHQ.block('jobsHQ-hotjobs-list', 28);
      }
      else {
        loadJobsHQ.singles(['jobsHQ-hotjobs-single'], 28);
      }
    };
  </script>
</div>
    <div class="sidebar newsletter">
            <div id="live-and-newsletter">
        
                <div id="newsletterSignup">
            


<section class="marketing-newsletter-image">
  <a href="javascript:newsletter();">
    <img class="imgDesktop" src="https://static.forumcomm.com/images/300x50/newsletter_signup.png" />
  </a>
</section>

<script>
  function newsletter(){
    window.parent.postMessage("click", "*");
  }
</script>
        </div>
      </div>
    </div>
    <div class="sidebar sidebar-mid"><div id="article-sidebar-container">
  <div id="article-sidebar">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-sidebar');
      });
      // Pass in the slot for the ad
      $(window).on("load", function() {
        $('#article-sidebar-container').lazyload('article-sidebar');
      });
    </script>
  </div>
</div>
</div>
    <div class="sidebar market-1">
      <div id="marketing-1-container">
  <div id="marketing-1">
    <script>
      googletag.cmd.push(function() {
        googletag.display('marketing-1');
      });
      $(window).on("load", function() {
        $('#marketing-1-container').lazyload('marketing-1');
      });
    </script>
  </div>
</div>
</div>
    <div class="sidebar origami">  <div id="origami-ad-container"></div>
  <script id="origami-ad-widget" src="https://origami.secure.ownlocal.com/origami-widget.js" data-partner-id="e73a44c7-bde3-463f-9611-d6f0e0a819c7"></script>
</div>
    <div class="sidebar motors-widget">
      <div id="motors-widget-container">
  <div id="motors-widget">
    <script>
      googletag.cmd.push(function() {
        googletag.display('motors-widget');
      });
      $(window).on("load", function() {
        $('#motors-widget-container').lazyload('motors-widget');
      });
    </script>
  </div>
</div>
    </div>
    <div class="sidebar tablet-2"><div id="article-tablet-2-container">
  <div id="article-tablet-2">
    <script>
      googletag.cmd.push(function() {
          googletag.display('article-tablet-2');
      });
      // Pass in the slot for the ad
      $(window).on("load", function() {
        $('#article-tablet-2-container').lazyload('article-tablet-2');
      });
    </script>
  </div>
</div>
</div>
    <div class="sidebar schema">        
          
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                  
    <div itemscope itemtype='http://schema.org/NewsArticle'>
    <meta itemprop='articleSection' content="Sports">
        <meta itemprop='dateline' content="Fargo,ND 55066">
    <meta itemprop='articleBody' content=" &lt;p&gt; The Pierce and Goodhue County area sports teams collectively had another successful year in 2019. These are some of the top moments of the year. &lt;/p&gt; &lt;p&gt; Seniors Jerron Matson, Seth Brossard and Tyler Craig all went out on top. The three led Kenyon-Wanamingo to a second-place finish in the team tournament, then days later each won a state title in their respective weight classes. &lt;/p&gt; &lt;p&gt; First was Matson at 120 pounds, who earlier in the season tore his meniscus and opted for surgery. Five weeks after the initial injury, he was back for the section quarterfinals and continued to wrestle through into state. &lt;/p&gt; &lt;p&gt; “I didn’t know how he would respond,” K-W head coach Matt Ryan said regarding how Matson would hold up in the state meet. “Jeron handled it well.” &lt;/p&gt; &lt;p&gt; At 152 pounds, Brossard took control in the second period and dominated in the third for the win. Ryan said Brossard had put in lots of work to be able to make a bid for a title that had eluded him in previous years. &lt;/p&gt; &lt;p&gt; “He did everything right,” Ryan said of Brossard’s year as a whole. “He did a great job of fending off the desperation (in the title match) and set a good pace throughout.” &lt;/p&gt; &lt;p&gt; Wrestling in the following match was Tyler Ryan. He had the same surgery as Matson much earlier in the season to repair a meniscus that tore for a second time. &lt;/p&gt; &lt;p&gt; Matt Ryan wasn’t sure what to expect of Tyler in the state title at 160 pounds. In a back-and-forth match, Tyler earned a takedown in the final 10 seconds of the third period to put him ahead by a point. It wound up being the winning takedown and it came as a big surprise to Matt. &lt;/p&gt; &lt;p&gt; “The last 10 seconds have changed how we feel today and how we’ll feel in the next five years,” Matt said. &lt;/p&gt; &lt;p&gt; Ten Pierce County wrestlers qualified for the individual state tournament last February. Ellsworth had eight of those qualifiers: Carter Huppert, Charlie Stuhl, Jared Lansing, Sawyer Hamilton, Logan Melstrom, Logan Peterson, Cedric Kosnopfal and Jared Toenjes. From Prescott there was Joe Schulte and Kenny Fesenmaier represented Spring Valley/Elmwood. &lt;/p&gt; &lt;p&gt; Stuhl (132-pounds) and Lansing (145) were the top finishers as both finished third in Division 2. Stuhl beat Edgerton’s Cole Bavery by a 4-0 decision in the third-place match while Lansing beat Zach Boehnlein of Chilton/Hilbert by an 11-0 major decision, his second win over Boehnlein of the tournament. &lt;/p&gt; &lt;p&gt; Toenjes (170) and Peterson (285) both took fifth for Ellsworth while Melstrom (195) finished sixth. Toenjes beat Tanner Goeman of Kewaskum by a 9-3 decision, second win over Goeman in just a few days. Peterson was up 12-0 in his fifth-place match before he pinned Belleville’s Daniel Enloe in the third period. Melstrom lost his fifth-place match to Belmont’s Will Schaefer by fall. Fesenmaier finished sixth for SVE after he lost to Fennimore’s Aaron Ragel by a 4-2 decision and finished his senior year with a record of 32-13.  &lt;/p&gt; &lt;p&gt; Hamilton (152) won his first match by a 5-2 decision over Gaven Lisowe of Chilton/Hilbert but then dropped his next two matches. Kosnopfal (160) lost his first match to Colton Worachek of Luxemburg-Casco by a 4-2 decision and was eliminated. For Prescott, Schulte (220) lost his first two matches at state.  &lt;/p&gt; &lt;p&gt; Of the eight wrestlers who competed at state last year, Huppert, Stuhl, Peterson and Schulte all look to return this year. &lt;/p&gt; &lt;p&gt; The Ellsworth wrestling team won their 14th-straight section championship last February and returned to the Division 2 team state tournament for the 14th time as well. It was also their record-tying 18th trip to team state overall. Ellsworth went on to make the state finals as the top seed but fell to No. 2 Freedom 35-16 to take second. &lt;/p&gt; &lt;p&gt; The Panthers cruised through Section A with blowout wins over Medford (53-15) in the semifinals and Spooner/Webster 51-18 in the final. Once at state, Ellsworth opened up by beating No. 4 Wisconsin Lutheran 50-18 in the semifinals. Wisconsin Lutheran took just four weight classes, one of which was a forfeit. Charlie Stuhl, Jared Lansing, Sawyer Hamilton, Cedric Kosnopfal, Logan Melstrom and Logan Peterson all got pins for the Panthers in the remaining 11 matches to cruise to victory. &lt;/p&gt; &lt;p&gt; The championship dual got off to a rough start for Ellsworth, which dropped the first three weights and trailed 9-0 until Stuhl won by major decision at 132-pounds. Lansing (145) and Hamilton (152) also collected major-decision wins to put the Panthers into a 12-12 tie with Freedom. Kosnopfal (170) put the Panthers ahead 16-15 with another major decision but from there it was all downhill for Ellsworth. Freedom took the final five matches to secure the win.  &lt;/p&gt; &lt;p&gt; Head coach Mark Matzek said at the time that his team had been sloppy in their win over Wisconsin Lutheran and that cost them against Freedom. &lt;/p&gt; &lt;p&gt; “We didn&#039;t show up, but that&#039;s ultimately my fault,&quot; Matzek said. &quot;I&#039;ve got to find out why didn&#039;t we. We showed up at the Clash; we wrestled better against Simley. Sectionals, you know, what was it? That&#039;s something for me to figure out.” &lt;/p&gt; &lt;p&gt; Co-captains Lansing and Stuhl agreed with their head coach. &lt;/p&gt; &lt;p&gt; &quot;I could tell from a while earlier that we weren&#039;t in it like we should have been,&quot; Lansing said. &quot;The feeling just wasn&#039;t right.&quot; &lt;/p&gt; &lt;p&gt; After getting bowled over by powerhouse Minnehaha Academy, the Lake City boys’ basketball team responded with a hard-fought 51-47 win over Perham in the third-place game at state. The win was the Tigers’ 28th of the season. Lake City head coach Greg Berge pointed out after the game that the Tigers only three losses in a 28-3 season were to teams with a top-10 player in the state (Breck, Rochester John Marshall, Minnehaha Academy). &lt;/p&gt; &lt;p&gt; “That&#039;s a phenomenal season,” Berge said of the wins and losses. “I think we&#039;ve won more games than any team in the history of Lake City basketball. I told the guys how special this season was. We&#039;re fortunate, we have four starters coming back.” &lt;/p&gt; &lt;p&gt; The win over Perham showed how exhausted the two teams were and how badly each wanted to end the season with a win. &lt;/p&gt; &lt;p&gt; “I told the guys this game is about your head and your heart,” Berge said. “You have to be mentally tough in your head today because you&#039;re going to get tired and you have to overcome that mentally. You have to have heart. It&#039;s the last game of your season. I thought they did it.” &lt;/p&gt; &lt;p&gt; Five hours after Winger Cecil Belisle won his second boys’ golf state title in three years, Sophia Yoemans won her third consecutive girls’ state title. The two became the fifth pair of golfers in state high school history to win an individual state title from the same school. The last time a boys’ and girls’ golfer from the same school won their respective title was, conveniently, Belisle and Yoemans in 2017. &lt;/p&gt; &lt;p&gt; Red Wing boys’ head coach Nate Gale said he knew Belisle could rebound from a triple-bogey on the first hole of the first round and Belisle did just that. In the second round on the 13th hole, Belisle went ahead with a birdie and played even the final five holes to capture the state title. &lt;/p&gt; &lt;p&gt; Yoemans finished ahead of teammate Leah Herzog for her third consecutive state title. Yoemans and Herzog didn’t know it until the final tally on the big scorecard outside the clubhouse was updated. They had led the Wingers to a team title, winning a single stroke. &lt;/p&gt; &lt;p&gt; Along with Yoemans and Herzog, Ashten Chandler, Grace Dube, Sydney Flack and Ava Bremseth shared the excitement of winning the team title. &lt;/p&gt; &lt;p&gt; “What a week we’ve had,” said Red Wing girls’ head coach Mark Herzog after the trophy presentations. “They’ve all been different people too. A state champion, then another is Ms. Minnesota, then the team title. There is something for everyone to celebrate, and they get to celebrate with their team, too.” &lt;/p&gt; &lt;p&gt; A year after finishing eighth in their section meet, the Prescott Cardinals girls’ golf team put together a historic season after advancing to the Division 2 state meet for the first time in program history. Prescott advanced to the section meet for just the third time in team history in 2018, but the Cardinals exploded in 2019 and racked up the accolades on their way to the state tournament. They finished second in the Middle Border Conference behind New Richmond and broke the Tigers’ five-year conference winning streak. &lt;/p&gt; &lt;p&gt; They had four players named All-Middle Border Conference – Alexis Fredericks, Jessica Heinsch, Liz Rohl and Ava Salay – while Salay, who is a freshman, was the MBC Player of the Year after earning medalist honors in all 10 conference meets. &lt;/p&gt; &lt;p&gt; The Cardinals won a regional championship on the way to the section tournament, where as a team they shot a 390 at Edgewood Sacred Heart to capture a section championship and their first trip to state. Over two days at University Ridge, Prescott shot a team score of 773 to finish second behind state-champion Edgewood (702) and 17 strokes ahead of MBC rival St. Croix Central, who finished third.  &lt;/p&gt; &lt;p&gt; “Overall I was thrilled with the outcome for our team,” Prescott’s head coach Chad Salay said. “Most of our girls have only one to two years of tournament experience — let alone state tournament experience — so for them to handle the pressure of a state tournament and perform as well as they did as a team, we are thrilled.” &lt;/p&gt; &lt;p&gt; Ava Salay finished second as an individual with a score of 166, 91 on day one and 85 on day two, eight strokes behind the champion and one ahead of the third-place finisher. &lt;/p&gt; &lt;p&gt; “Still, for (Ava) to pull out a runner-up against a very solid field of state golfers that were giving her a real run that second day, she has a lot to be proud of and she gained some invaluable experience,” coach Salay said. “I have a pretty good source that says she will come back pretty hungry next season.” &lt;/p&gt; &lt;p&gt; Prescott returns four of their five varsity players next year, all four of whom were underclassmen this year. However, they do lose Fredericks, who was a rock for the Cardinals throughout her career during the seasons leading up to 2019.  &lt;/p&gt; &lt;p&gt; A pair of Pierce County and Middle Border Conference teams qualified for their respective state tournaments this past spring. After having high hopes for the 2018 season that didn’t quite turn out, the Ellsworth softball team advanced to Division 2 state tournament with a talented roster, most of which returns for the 2020 season. Meanwhile, Prescott softball went to the Division 3 state tournament for the second year in a row. &lt;/p&gt; &lt;p&gt; The Cardinals beat the Bloomer Blackhawks 6-4 in the section championship game while Ellsworth beat Merrill 4-1 to advance to state. Prescott went on to face Poynette in the state semifinals, which had a 40-plus game winning streak. The Panthers drew the No. 2-seeded Seymour Thunder. &lt;/p&gt; &lt;p&gt; Both teams lost in their semifinal games to end their state runs, though both Poynette and Seymour went on to win their respective state championships. Seymour took a 3-0 lead over Ellsworth in the third inning and made it 4-0 in the top of the fourth. Claire Kummer was responsible for both of the Panthers’ runs – she scored on an error in the bottom of the fourth and then doubled and scored on a Kaitlyn Nugent RBI-single – but they could not complete the comeback and lost 4-2. Ellsworth finished the season with a 24-3 record and returns almost the entire team in 2020. &lt;/p&gt; &lt;p&gt; Prescott was shutout by Poynette 7-0 in their semifinal match. The Cardinals managed just two hits as Poynette pitcher Casey Fountain notched 14 strikeouts and Prescott had just three total base runners for the game.  &lt;/p&gt; &lt;p&gt; In the program’s history, Randolph had never made it to the state tournament in baseball. In 2018, the Rockets needed just one win in the section finals to advance, but fell in back-to-back games. &lt;/p&gt; &lt;p&gt; Tired of collecting red ribbons, the Rockets took care of Goodhue in the 2019 section finals and secured its first section title and first trip to the state tournament. &lt;/p&gt; &lt;p&gt; In the state tournament, the Rockets lost 10-0 to Kerkhoven-Murdock-Sunburg, beat Sebeka 11-1, then lost in the consolation championship 16-5 to Hayfield. &lt;/p&gt; &lt;p&gt; The Rockets weren’t given any medals nor any trophies to signify a trip to state. What the team did get was a chance to make some memories. The players enjoyed their stay in the Cities. The parents were able to applaud the efforts of the seniors one final time as they were individually pulled from the game against Hayfield in the middle of the top of the sixth. Maybe more importantly, the community will remember the 2019 Rockets for a long time. &lt;/p&gt; &lt;p&gt; “On the boys&#039; side there has only been one other team to get to that point,” said Randolph head coach Chris Stanton. “(This team) showed that they can do it. Credit to our softball team, when they broke through last year it helped the boys have that mentality of we can do this too. They all shared a common goal. It&#039;s going to be one I&#039;ll never forget.” &lt;/p&gt; &lt;p&gt; Stanton told his players one last thing before letting the seniors leave the final postgame team meeting. &lt;/p&gt; &lt;p&gt; “In Randolph, you&#039;ll be remembered forever,” Stanton said.. “We talk about the 1979 football team forever. They are going to talk about the 2019 (baseball) team for a long time.” &lt;/p&gt; &lt;p&gt; For the seniors, it was about leaving a mark. &lt;/p&gt; &lt;p&gt; “We always get that, ‘Where’s Randolph?’ thing,” said senior Joey Erickson. “You want people to stop saying that and we tried to do that (by playing in the tournament).” &lt;/p&gt; &lt;p&gt; The No. 9-ranked Cannon Falls football team advanced to its third state tournament with a 40-13 win over Breck in the Section 4AAA championship. &lt;/p&gt; &lt;p&gt; “This is only the third Cannon Falls team to ever make it to state and obviously we&#039;re going to celebrate,” said Cannon Falls head coach Dan Meyers, “but we will probably wait until the season is over to really celebrate what&#039;s going on because we have another game next week. We told our guys to have fun and enjoy this one ... But we have to come back Monday. We would love to keep going. From here on it keeps getting bigger and bigger, and more fun.” &lt;/p&gt; &lt;p&gt; Breck running back Derek Turner muffed the opening kickoff and the Bombers recovered, setting up their first score of the game. The momentum remained on the Bomber sideline as the Mustangs had no answer for the Bomber runners and defensive line. &lt;/p&gt; &lt;p&gt; By the end of the first half, the Bombers led by a comfortable 34-7 margin. &lt;/p&gt; &lt;p&gt; “We have a lot of games like (this one) where we&#039;ve been up big at halftime and been able to use some other guys,” Meyers said, “which is nice over the course of a long season to get some rest for the starters. I would attribute it to our guys being really diligent at practice.” &lt;/p&gt; &lt;p&gt; 2019 marked the third trip to state for Cannon Falls. The first came back in 1996. &lt;/p&gt; &lt;p&gt; The Spring Valley Cardinals finally broke through and made it to the Level 3 playoffs this fall after being unable to advance past Level 2 the previous three years. A huge part of that breakthrough were the efforts of the senior class, led by quarterback Aaron Borgerding, which took the Cardinals to another level. &lt;/p&gt; &lt;p&gt; “Our sophomore year, we weren’t really sure how we were going to impact the game,” Borgerding said. “Our senior class helped change the culture of our team. Our comradery and what we did together … This group of guys is just so fun to be with. We just play for each other. We don’t really play against the other team. We play to better ourselves and just have fun with one another.” &lt;/p&gt; &lt;p&gt; Spring Valley went 8-1 during the regular season and finished second in the Dunn-St.Croix Conference (5-1), a game behind champion Mondovi who the Cardinals lost to by three points in week 8. They then blew out DSC-opponent Durand 34-14 in the first round of the playoffs and Unity 47-20 in the second round. This setup a Level 3-matchup against Regis, who Spring Valley had lost to in the playoffs the previous two years. &lt;/p&gt; &lt;p&gt; Heading into the game, Regis was undefeated and averaging over 45 points per game. However, Spring Valley held the Ramblers to just eight first-half points and the game was tied 8-8 at halftime. The Cardinals blocked a Regis punt for a safety and Borgerding scored on a 28-yard touchdown run. In the second half, the Ramblers steadily pulled away to a 29-8 win. It was the fewest points Regis was held to all season up to that point.  &lt;/p&gt; &lt;p&gt; “I felt like we did some things well when this senior group was younger, but I feel like this senior group really took control of the culture and took it to another level that we weren’t at before,” said Spring Valley head coach Ryan Kapping said. “Putting in the weight room as well as just supporting each other and hanging out with each other and really having that genuine love for each other, they’ve set a really good year for next year’s seniors.” &lt;/p&gt;">
    <span itemprop='headline'>
      <meta itemprop='headline' content="Top-10 Republican Eagle Sports Stories: Plenty of success at state">
      <meta itemprop='author' content="RE Sports">
      <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
          <meta itemprop="url" content="/theme/images/social_default_image.png">
          <meta itemprop="width" content="128">
          <meta itemprop="height" content="128">
        </div>
        <meta itemprop="name" content="rivertowns">
      </div>
      <meta itemprop='datePublished' content="2020-01-02T19:48:51.000Z">
      <meta itemprop='dateModified' content="2020-01-02T21:22:56.000Z">
      <link itemprop='mainEntityOfPage' content="/sports/4847241-Top-10-Republican-Eagle-Sports-Stories-Plenty-of-success-at-state">
    </span>
          <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject">
        <meta itemprop="url" content="https://www.rivertowns.net/incoming/4847313-oqzy3x-Top-10-Randolph-Section-Baseball.jpg/alternates/BASE_LANDSCAPE/Top-10%20Randolph%20Section%20Baseball.jpg">
        <meta itemprop="width" content="1140">
        <meta itemprop="height" content="712">
      </span>
        <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'>
      <meta itemprop='author' content="RE Sports">
    </div>
    <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'>
      <meta itemprop='name' content="Top-10 Republican Eagle Sports Stories: Plenty of success at state">
    </div>
        <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'>
      <meta itemprop='addressLocality' content="Red Wing">
      <meta itemprop='addressRegion' content="MN">
      <meta itemprop='streetAddress' content="2760 N Service Drive">
      <meta itemprop='postalCode' content="55066">
    </div>
  </div>
  </div>

  </div>

</div>
                        </div>
    
      <div id="banner-3-container">
  <div id="banner-3">
    <script>
      googletag.cmd.push(function() {
          googletag.display('banner-3');
      });
      // Pass in the slot name for the ad
      $(window).on("load", function() {
        $("#banner-3-container").lazyload('banner-3');
      });
    </script>
  </div>
</div>
  <div id="in-page">
  <script>
    googletag.cmd.push(function() {
      googletag.display('in-page');
    });
    $(window).ready(function() {
      // refreshBid('in-page', 'in_page');
      googletag.pubads().refresh([window['in_page']]);
    });
  </script>
</div>
  
<footer class="footer white">
  <div class="footer-block">
      

          

<div class="footer nav-group">
      <div class="footer nav-block">
      <h3 class="white-header" title="Account">Account</h3>      <ul>
                  <li><a class="white-link" href="https://www.rivertowns.net/account/" title="Manage My Account" target="_self" tabindex="1">Manage My Account</a></li>
                  <li><a class="white-link" href="/privacy/" title="Privacy Policy" target="_self" tabindex="1">Privacy Policy</a></li>
                  <li><a class="white-link" href="/terms/" title="Terms and Conditions" target="_self" tabindex="1">Terms and Conditions</a></li>
              </ul>
    </div>
      <div class="footer nav-block">
      <h3 class="white-header" title="Newspaper">Newspaper</h3>      <ul>
                  <li><a class="white-link" href="http://www.forumnewspaper.com/rivertown/" title="Subscribe to the Paper" target="_self" tabindex="1">Subscribe to the Paper</a></li>
                  <li><a class="white-link" href="/account/e-paper" title="Access E-Paper" target="_self" tabindex="1">Access E-Paper</a></li>
                  <li><a class="white-link" href="javascript:footerNewsletter();" title="Sign Up for E-Newsletters" target="_self" tabindex="1">Sign Up for E-Newsletters</a></li>
              </ul>
    </div>
      <div class="footer nav-block">
      <h3 class="white-header" title="Contact">Contact</h3>      <ul>
                  <li><a class="white-link" href="/rivertowns-contact-us" title="Contact Us" target="_self" tabindex="1">Contact Us</a></li>
                  <li><a class="white-link" href="/help-center" title="Get Website Help" target="_self" tabindex="1">Get Website Help</a></li>
                  <li><a class="white-link" href="http://www.forumcomm.com/careers" title="Work with Us" target="_blank" tabindex="1">Work with Us</a></li>
              </ul>
    </div>
      <div class="footer nav-block">
      <h3 class="white-header" title="More">More</h3>      <ul>
                  <li><a class="white-link" href="https://www.jobshq.com" title="JobsHQ" target="_blank" tabindex="1">JobsHQ</a></li>
                  <li><a class="white-link" href="http://www.carshq.com" title="Motors" target="_blank" tabindex="1">Motors</a></li>
                  <li><a class="white-link" href="https://www.homeshq.com/fargo-nd" title="HomesHQ" target="_blank" tabindex="1">HomesHQ</a></li>
                  <li><a class="white-link" href="http://www.northlandoutdoors.com" title="Northland Outdoors" target="_blank" tabindex="1">Northland Outdoors</a></li>
                  <li><a class="white-link" href="https://www.agweek.com" title="Agweek" target="_blank" tabindex="1">Agweek</a></li>
                  <li><a class="white-link" href="http://impact.areavoices.com" title="Impact Magazine" target="_blank" tabindex="1">Impact Magazine</a></li>
              </ul>
    </div>
  </div>

<script>
  function footerNewsletter(){
    window.parent.postMessage("footerClick", "*");
  }
</script>

      
<div class="footer nav-block social">
    <h3 class="white-header" title="Social">Social</h3>
    <ul class="social">
                          <li class="twitter"> <a href="https://twitter.com/RiverTown_News" class="link secondary" title="Find us on Twitter" target="_blank">
  <svg class="icon-twitter" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 30 32">
    <path d="M29.5 6.875c-.813 1.25-1.813 2.25-3 3.125v.75c0 8-6.125 17.25-17.25 17.25-3.438 0-6.563-1-9.25-2.75.5.063.938.125 1.438.125 2.813 0 5.438-1 7.5-2.625-2.625-.063-4.875-1.813-5.625-4.188.375.063.75.125 1.125.125.563 0 1.125-.125 1.625-.25-2.75-.563-4.875-3-4.875-5.938v-.063c.813.438 1.75.75 2.75.75-1.625-1.063-2.688-2.938-2.688-5.063 0-1.125.313-2.125.813-3 3 3.688 7.438 6.063 12.438 6.313-.125-.438-.125-.875-.125-1.375a6.03 6.03 0 0 1 6.063-6.063c1.75 0 3.25.75 4.375 1.938 1.375-.25 2.688-.813 3.875-1.5-.438 1.438-1.438 2.625-2.688 3.375 1.25-.125 2.438-.438 3.5-.938z"></path>
</svg></a>
 </li>
                          <li class="facebook"> <a href="https://www.facebook.com/RiverTownsnet-170276059664268/" class="link secondary" title="Find us on Facebook" target="_blank">
  <svg class="icon-facebook" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 12 32">
    <path d="M8 12h4l-.5 4H8v12H2.812V16H-.001v-4h2.813V9.312c0-3.375 1.438-5.313 5.688-5.313H12v4H9.875C8.187 7.999 8 8.562 8 9.624v2.375z"></path>
</svg></a>
 </li>
                <li class="rss"> 
<a href="/latest/rss/" class="link secondary" title="Our rss feed" target="_blank">
  <svg class="icon-rss" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32">
    <path d="M4.259 23.467A4.265 4.265 0 0 0 0 27.719a4.25 4.25 0 0 0 4.259 4.244 4.25 4.25 0 0 0 4.265-4.244 4.265 4.265 0 0 0-4.265-4.252zM.005 10.873v6.133c3.993 0 7.749 1.562 10.577 4.391A14.897 14.897 0 0 1 14.966 32h6.16c0-11.651-9.478-21.127-21.121-21.127zM.012 0v6.136C14.255 6.136 25.848 17.74 25.848 32H32C32 14.36 17.648 0 .012 0z"></path>
</svg></a>
 </li>
    </ul>

</div>

      <div class="footer copyright">
    
<div class="footer company">
    © RiverTowns and
    <a class="company" href="http://www.forumcomm.com/" target="_blank">Forum Communications Company</a>
</div>
    <br>
    
<div class="footer company-location">
  <div class="footer company-address">2760 N Service Drive,
                                      Red Wing,
                                      MN
                                      55066</div>
  <div class="footer company-phone">(800) 535-1660</div>
</div>
</div>  </div>
     <div class="line"></div>
</footer>

    
<link rel="stylesheet" href="https://static.forumcomm.com/css/all.css">
<script src="https://cdnjs.cloudflare.com/ajax/libs/moment.js/2.22.2/moment.min.js"></script>
<script src="/theme/js/jwplayer/jwplayer.js"></script>
<script src="/theme/js/sss.min.js"></script>
<script src="/theme/js/jquery.oembed.js"></script>
<script src="/theme/js/main.js"></script>
<script src="/theme/js/embed-card.js"></script>
<script src="/theme/js/poll.js"></script>
<script src="/theme/js/owl.carousel.min.js"></script>



        <!-- Piano Implementation -->


    

  
              
        
  <script>
  //check url for newsletter_subscribed utm and add cookie
  $(document).ready(function () {
    if(window.location.href.indexOf("?utm_sub=newsletter_subscribed") > -1) {
      var exdays = 90;
      var d = new Date();
      d.setTime(d.getTime() + (exdays*24*60*60*1000));
      var cookieName = "_pc_rivertowns_newsletter=signedup;";
      var expires = "expires=" + d.toUTCString() + ";";
      document.cookie = cookieName + expires + " path=/";
    }
  });
  </script>

    <script>
    (function(src) {
      var a = document.createElement("script");
      a.type = "text/javascript";
      a.async = true;
      a.src = src;
      var b = document.getElementsByTagName("script")[0];
      b.parentNode.insertBefore(a, b)
    })("//experience.tinypass.com/xbuilder/experience/load?aid=tzWJplhGys");
  </script>

    <script>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</script>

    <script>tp.push(["setUsePianoIdUserProvider", true ]);</script>

      <script>console.log("Production Environment");</script>
  
  </body>
</html>
